Start a new topic
Solved

Error Message could not be sent. Mailer Error: SMTP connect() failed.

I've entered the correct SMTP settings but I get this message "Error Message could not be sent. Mailer Error: SMTP connect() failed." Please help

Hi Ahmed,

Please check your SMTP username and password on the Settings > E-mails page in your admin panel.

Have you been able to set up this mail server in your desktop mail client?

Thank you.

 

Hi Arina,


I'm able to set it up on my other clients, with the same username and password and different user accounts, still receiving the same message.


Thank you

Hi Ahmed,

Thank you for the information.

I have forwarded this information to our software engineers for the examination. We'll contact you as soon as we have any news from them.

Thank you.

 

Hi Arina,


Any update please? Appreciate if you fix this so I can launch the website soon.

Hello Ahmed,


Thank you for patience.

The issue was caused by incorrect SMTP settings. First, the SMTP port was not specified in the SMTP host field, so we added it. After that we got the Data not accepted error (we tested email sending by updating the customer profile). It happened because the email address set in the User department e-mail address field on the Settings > Company page did not match the address set in the SMTP username field. So actually, all the company email addresses should match the one set in the SMTP username field, it is a requirement of your SMTP service: 


https://www.zoho.com/mail/help/zoho-smtp.html

So we changed the address in the User department e-mail address field, updated our profile and got the email (please have a look at the screenshots attached). Please change emails in other fields on the Settings > Company page.

Thank you.


Thank you very much. Using SMTP ensures (not 100%) the emails reach the inbox not Spam folder, but I've tried using several accounts and still receiving the email notifications in the Spam folder. Can you do something about that?

Hello Ahmed,


It seems the issue is caused by your email client settings (filters) because email message, which was sent during our previous examination, went to the Inbox folder of our account. Please check those settings.


Thank you.


Login or Signup to post a comment