Start a new topic

forbidden errors for json script tag request


 When we sent a json request for the script tags, it gives a forbidden error. Could you let us know why. We are passing the access token in the header

sontring is ..{"src":"https://www.neowauk.com/EventProvider/merchiummodelint_c123store-nut1.mymerchium.com.js"}
responsebg2: HTTP/1.1 403 Forbidden [Server: nginx, Date: Mon, 16 Mar 2015 01:27:26 GMT, Content-Type: application/json, Transfer-Encoding: chunked, Vary: Accept-Encoding, Last-Modified: Mon, 16 Mar 2015 01:27:26 GMT, Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0, Pragma: no-cache, Expires: -1]

We've checked the ScriptTag creating routine. Everything seems to work fine.
 
Here's the snippet we used for the check; it's a terminal command with curl. It may help you locate the error in your app:

curl -X POST 'http://[mystore].mymerchium.com/api/script_tags' --header 'X-Merchium-Access-Token: [api_key]' --header 'Content-Type: application/json' -d '{"src":"https:\/\/www.neowauk.com\/EventProvider\/merchiummodelint_c123store-nut1.mymerchium.com.js"}'‏

 

Is there a way you can point why I am getting the forbidden error. I tried Curl and I am seeing forbidden error

there as well. Can you guys check your logs and point out why, I am getting the forbidden error.


Thanks for ur help

Could you please reinstall the app in your development store?

Tried again and got the same error. You also should be able to intall the App now, incase you need to replicate .

I've actually tried creating a script tag in your store and with your app's ACCESS TOKEN, and it worked.
 
I've sent you an email with the curl code I used for the test.


Hi Dmitry,


My Bad. There was a typo in the request.( An additional ":") . Thanks for the help and issue is fixed now.


Apologize for the confusion caused.


Jacob


Login or Signup to post a comment